【Linuxサーバー】ServersMan@VPSでCentOS7はオススメできない

どういうことか

yum updateをすると以下のようなエラーが出る。

Error: systemd conflicts with initscripts-9.49.17-1.el7_0.1.x86_64
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

このinitscriptsのアップデートでエラーが出るのが問題で、yum updateだけじゃなく、他のツールをインストールする時にも依存関係でこのエラーが出る。ということは必要なツールをインストールまたはアップデートできない。

実際このエラーを回避しながら運用する方法があるのかもしれないけど、自分はRailsのアプリをインストールするためのRubyをインストールするためのrbenvをインストールするためのopenssl-develがインストールできなかったので諦めました。

エラー出る段階が早すぎて、回避策調べる気が起こらん。

参考
CentOS 7と相性が悪いVPS | 技術系のメモ

他の人も結構書いてる

Google検索

エラー報告から使えん!っていう記事まで。

逆に言うと

initscriptsのアップデートができるようになれば安く使える良いサーバーってことかな?

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です